CVE-2009-4214

NameCVE-2009-4214
DescriptionCross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2260-1, DSA-2301-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs558685
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
stretch, sid, jessie2:4.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2.2.3-2low558685
railssourcelenny2.1.0-7+lenny1mediumDSA-2301-1
railssourcesqueeze2.3.5-1.2+squeeze1mediumDSA-2301-1

Notes

http://groups.google.com/group/rubyonrails-security/browse_thread/thread/4d4f71f2aef4c0ab?pli=1

Search for package or bug name: Reporting problems