CVE-2009-4261

NameCVE-2009-4261
DescriptionMultiple directory traversal vulnerabilities in the iallocator framework in Ganeti 1.2.4 through 1.2.8, 2.0.0 through 2.0.4, and 2.1.0 before 2.1.0~rc2 allow (1) remote attackers to execute arbitrary programs via a crafted external script name supplied through the HTTP remote API (RAPI) and allow (2) local users to execute arbitrary programs and gain privileges via a crafted external script name supplied through a gnt-* command, related to "path sanitization errors."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1959-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ganeti (PTS)wheezy, wheezy (security)2.5.2-1+deb7u2fixed
jessie (security), jessie2.12.4-1+deb8u3fixed
stretch2.15.2-7fixed
buster, sid2.15.2-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ganetisource(unstable)2.0.5-1low
ganetisourcelenny1.2.6-3+lenny2highDSA-1959-1

Notes

http://www.ocert.org/advisories/ocert-2009-019.html

Search for package or bug name: Reporting problems