CVE-2009-4270

NameCVE-2009-4270
DescriptionStack-based buffer overflow in the errprintf function in base/gsmisc.c in ghostscript 8.64 through 8.70 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PDF file, as originally reported for debug logging code in gdevcups.c in the CUPS output driver.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2080-1
NVD severityhigh (attack range: remote)
Debian Bugs562643

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2fixed
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie9.06~dfsg-2+deb8u5fixed
jessie (security)9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)8.70~dfsg-2.1medium562643
ghostscriptsourcelenny8.62.dfsg.1-3.2lenny4highDSA-2080-1

Search for package or bug name: Reporting problems