CVE-2009-4274

NameCVE-2009-4274
DescriptionStack-based buffer overflow in converter/ppm/xpmtoppm.c in netpbm before 10.47.07 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via an XPM image file that contains a crafted header field associated with a large color index value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2026-1, DTSA-206-1
NVD severityhigh (attack range: remote)
Debian Bugs569060

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netpbm-free (PTS)wheezy2:10.0-15fixed
jessie2:10.0-15.2fixed
buster, stretch, sid2:10.0-15.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netpbm-freesource(unstable)2:10.0-12.2medium569060
netpbm-freesourcelenny2:10.0-12+lenny1highDSA-2026-1
netpbm-freesourcesqueeze2:10.0-12.1+squeeze1highDTSA-206-1

Search for package or bug name: Reporting problems