CVE-2009-4880

NameCVE-2009-4880
DescriptionMultiple integer overflows in the strfmon implementation in the GNU C Library (aka glibc or libc6) 2.10.1 and earlier allow context-dependent attackers to cause a denial of service (memory consumption or application crash) via a crafted format string, as demonstrated by a crafted first argument to the money_format function in PHP, a related issue to CVE-2008-1391.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2058-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)squeeze2.11.3-4fixed
squeeze (lts)2.11.3-4+deb6u6fixed
wheezy2.13-38+deb7u6fixed
wheezy (security)2.13-38+deb7u8fixed
glibc (PTS)stretch, sid, jessie2.19-18fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)2.11.1-1unimportant
glibcsource(unstable)2.11.1-1unimportant
glibcsourcelenny2.7-18lenny4mediumDSA-2058-1

Notes

http://sourceware.org/git/?p=glibc.git;a=commit;h=199eb0de8d673fb23aa127721054b4f1803d61f3

Search for package or bug name: Reporting problems