CVE-2009-5010

NameCVE-2009-5010
DescriptionRace condition in the FTPHandler class in ftpserver.py in pyftpdlib before 0.5.1 allows remote attackers to cause a denial of service (daemon outage) by establishing and then immediately closing a TCP connection, leading to the accept function having an unexpected return value of None, a different vulnerability than CVE-2010-3494.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pyftpdlib (PTS)buster1.5.4-1fixed
bullseye1.5.4-2fixed
bookworm, sid1.5.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pyftpdlibsource(unstable)(not affected)

Notes

- python-pyftpdlib <not-affected> (Fixed before initial upload to the archive)

Search for package or bug name: Reporting problems