CVE-2009-5053

NameCVE-2009-5053
DescriptionUnspecified vulnerability in Smarty before 3.0.0 beta 6 allows remote attackers to execute arbitrary PHP code by injecting this code into a cache file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)buster, buster (security)3.1.33+20180830.1.3a78a21f+selfpack1-1+deb10u1fixed
bullseye (security), bullseye3.1.39-2+deb11u1fixed
bookworm, sid3.1.47-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smartysourcesqueeze(unfixed)end-of-life
smartysource(unstable)(unfixed)
smarty3source(unstable)3.0~rc1-1

Notes

[squeeze] - smarty <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems