DescriptionGnuTLS before 2.7.6, when the GNUTLS_VERIFY_ALLOW_X509_V1_CA_CRT flag is not enabled, treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates, a different vulnerability than CVE-2014-1959.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy, wheezy (security)2.12.20-8+deb7u5fixed
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch (security)3.5.8-5+deb9u1fixed
buster, sid3.5.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28source(unstable)(not affected)


- gnutls28 <not-affected> (Only affects versions before 2.7.6)
Only affects version prior of 2.7.6, fix:
and the issue has different root than CVE-2014-1959

Search for package or bug name: Reporting problems