CVE-2009-5155

NameCVE-2009-5155
DescriptionIn the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs924613

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)jessie (security), jessie2.19-18+deb8u10vulnerable
stretch2.24-11+deb9u4vulnerable
stretch (security)2.24-11+deb9u1vulnerable
buster, sid2.28-10fixed
gnulib (PTS)jessie20140202+stable-2vulnerable
jessie (security)20140202+stable-2+deb8u1vulnerable
stretch20140202+stable-2+deb9u1vulnerable
buster, sid20140202+stable-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
glibcsource(unstable)2.28-1medium
gnulibsource(unstable)20140202+stable-3.2medium924613
gnulibsourceexperimental20180621~6979c25-1medium

Notes

[stretch] - gnulib <no-dsa> (Minor issue)
[jessie] - gnulib <no-dsa> (Minor issue)
[stretch] - glibc <no-dsa> (Minor issue)
[jessie] - glibc <no-dsa> (Minor issue)
http://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=5513b40999149090987a0341c018d05d3eea1272
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=22793
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32806
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34238
https://sourceware.org/bugzilla/show_bug.cgi?id=11053
https://sourceware.org/bugzilla/show_bug.cgi?id=18986
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=eb04c21373e2a2885f3d52ff192b0499afe3c672

Search for package or bug name: Reporting problems