CVE-2010-0385

NameCVE-2010-0385
DescriptionTor before 0.2.1.22, and 0.2.2.x before 0.2.2.7-alpha, when functioning as a bridge directory authority, allows remote attackers to obtain sensitive information about bridge identities and bridge descriptors via a dbg-stability.txt directory query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)stretch0.2.9.16-1fixed
stretch (security)0.2.9.15-1fixed
buster, buster (security)0.3.5.14-1fixed
bullseye, sid0.4.5.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsourcelenny(not affected)
torsource(unstable)0.2.1.22-1low

Notes

[lenny] - tor <not-affected> (only affects versions > 0.2.1.6-alpha)
the CVE entry is wrong, only 0.2.1.6-alpha and up are affected
confirmed with Tor developers, Lenny is not affected

Search for package or bug name: Reporting problems