CVE-2010-0394

NameCVE-2010-0394
DescriptionPyGIT.py in the Trac Git plugin (trac-git) before 0.0.20080710-3+lenny1 and before 0.0.20090320-1 on Debian GNU/Linux, when enabled in Trac, allows remote attackers to execute arbitrary commands via shell metacharacters in a crafted HTTP query that is used to generate a certain git command.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1990-1, DSA-1990-2
NVD severitymedium (attack range: remote)
Debian Bugs567039
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trac-git (PTS)squeeze0.0.20100513-2fixed
wheezy0.12.0.5+722342e-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trac-gitsource(unstable)0.0.20090320-1high567039
trac-gitsourcelenny0.0.20080710-3+lenny2mediumDSA-1990-2

Search for package or bug name: Reporting problems