CVE-2010-0405

NameCVE-2010-0405
DescriptionInteger overflow in the BZ2_decompress function in decompress.c in bzip2 and libbzip2 before 1.0.6 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted compressed file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2112-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bzip2 (PTS)squeeze1.0.5-6+squeeze1fixed
wheezy1.0.6-4fixed
stretch, sid, jessie1.0.6-7fixed
clamav (PTS)squeeze0.98.1+dfsg-1+deb6u3fixed
squeeze (lts)0.98.1+dfsg-1+deb6u4fixed
wheezy0.98.5+dfsg-0+deb7u2fixed
stretch, jessie0.98.6+dfsg-1fixed
sid0.98.6+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bzip2source(unstable)1.0.5-6medium
bzip2sourcelenny1.0.5-1+lenny1mediumDSA-2112-1
clamavsource(unstable)0.96.3+dfsg-1medium
clamavsourcelenny(unfixed)end-of-life

Notes

[lenny] - clamav <end-of-life> (No longer supported in Lenny)

Search for package or bug name: Reporting problems