CVE-2010-0407

NameCVE-2010-0407
DescriptionMultiple buffer overflows in the MSGFunctionDemarshall function in winscard_svc.c in the PC/SC Smart Card daemon (aka PCSCD) in MUSCLE PCSC-Lite before 1.5.4 allow local users to gain privileges via crafted message data, which is improperly demarshalled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2059-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcsc-lite (PTS)wheezy1.8.4-1+deb7u1fixed
wheezy (security)1.8.4-1+deb7u2fixed
jessie (security), jessie1.8.13-1+deb8u1fixed
stretch1.8.20-1fixed
buster, sid1.8.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcsc-litesource(unstable)1.5.4-1medium
pcsc-litesourcelenny1.4.102-1+lenny1mediumDSA-2059-1

Search for package or bug name: Reporting problems