CVE-2010-0436

NameCVE-2010-0436
DescriptionRace condition in backend/ctrl.c in KDM in KDE Software Compilation (SC) 2.2.0 through 4.4.2 allows local users to change the permissions of arbitrary files, and consequently gain privileges, by blocking the removal of a certain directory that contains a control socket, related to improper interaction with ksm.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2037-1
NVD severitymedium (attack range: local)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdebasesource(unstable)4:4.0medium
kdebasesourcelenny4:3.5.9.dfsg.1-6+lenny1mediumDSA-2037-1
kdebase-workspacesource(unstable)4:4.4.3-1medium

Notes

The binary package kdm was built from kdebase in Lenny and from kdebase-workspace
in KDE 4.x, i.e. Squeeze onwards

Search for package or bug name: Reporting problems