CVE-2010-0628

NameCVE-2010-0628
DescriptionThe spnego_gss_accept_sec_context function in lib/gssapi/spnego/spnego_mech.c in the SPNEGO GSS-API functionality in MIT Kerberos 5 (aka krb5) 1.7 before 1.7.2 and 1.8 before 1.8.1 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via an invalid packet that triggers incorrect preparation of an error token.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs575740

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1fixed
stretch (security)1.15-1+deb9u2fixed
buster1.17-3+deb10u1fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6fixed
bookworm, sid1.18.3-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcelenny(not affected)
krb5source(unstable)1.8+dfsg-1.1575740

Notes

[lenny] - krb5 <not-affected> (Only affects 1.7/1.8)

Search for package or bug name: Reporting problems