CVE-2010-0829

NameCVE-2010-0829
DescriptionMultiple array index errors in set.c in dvipng 1.11 and 1.12, and teTeX, allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a malformed DVI file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2048-1
NVD severitymedium (attack range: remote)
Debian Bugs580628

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dvipng (PTS)wheezy1.14-1fixed
buster, sid, jessie, stretch1.14-2fixed
texlive-bin (PTS)wheezy2012.20120628-4fixed
jessie2014.20140926.35254-6fixed
stretch2016.20160513.41080.dfsg-2fixed
buster, sid2017.20170613.44572-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dvipngsource(unstable)1.13-1low580628
dvipngsourcelenny1.11-1+lenny1mediumDSA-2048-1
texlive-binsource(unstable)(not affected)

Notes

- texlive-bin <not-affected> (dvipng is not shipped in texlive-bin Debian packages)

Search for package or bug name: Reporting problems