CVE-2010-1321

NameCVE-2010-1321
DescriptionThe kg_accept_krb5 function in krb5/accept_sec_context.c in the GSS-API library in MIT Kerberos 5 (aka krb5) through 1.7.1 and 1.8 before 1.8.2, as used in kadmind and other applications, does not properly check for invalid GSS-API tokens, which allows remote authenticated users to cause a denial of service (NULL pointer dereference and daemon crash) via an AP-REQ message in which the authenticator's checksum field is missing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2052-1
NVD severitymedium (attack range: remote)
Debian Bugs582261

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heimdal (PTS)wheezy1.6~git20120403+dfsg1-2fixed
wheezy (security)1.6~git20120403+dfsg1-2+deb7u1fixed
jessie (security), jessie1.6~rc2+dfsg-9+deb8u1fixed
stretch (security), stretch7.1.0+dfsg-13+deb9u1fixed
buster, sid7.4.0.dfsg.1-2fixed
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie (security), jessie1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heimdalsource(unstable)1.4.0~git20100605.dfsg.1-1medium
krb5source(unstable)1.8.1+dfsg-3low582261
krb5sourcelenny1.6.dfsg.4~beta1-5lenny4mediumDSA-2052-1
sun-java6source(unstable)6.22-1medium
sun-java6sourcelenny6-22-0lennymedium

Search for package or bug name: Reporting problems