CVE-2010-1431

NameCVE-2010-1431
DescriptionSQL injection vulnerability in templates_export.php in Cacti 0.8.7e and earlier allows remote attackers to execute arbitrary SQL commands via the export_item_id parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2039-1
NVD severityhigh
Debian Bugs578909

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcelenny0.8.7b-2.1+lenny2DSA-2039-1
cactisource(unstable)0.8.7e-3578909

Notes

http://seclists.org/fulldisclosure/2010/Apr/272
http://www.cacti.net/downloads/patches/0.8.7e/sql_injection_template_export.patch

Search for package or bug name: Reporting problems