CVE-2010-1441

NameCVE-2010-1441
DescriptionMultiple heap-based buffer overflows in VideoLAN VLC media player before 1.0.6 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted byte stream to the (1) A/52, (2) DTS, or (3) MPEG Audio decoder.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze (security), squeeze1.1.3-1squeeze6fixed
wheezy2.0.3-5+deb7u1fixed
wheezy (security)2.0.3-5+deb7u2fixed
jessie, sid2.2.0~rc2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)1.0.6-1high
vlcsourcelenny0.8.6.h-4+lenny3high

Notes

http://www.videolan.org/security/sa1003.html

Search for package or bug name: Reporting problems