CVE-2010-1447

NameCVE-2010-1447
DescriptionThe Safe (aka Safe.pm) module 2.26, and certain earlier versions, for Perl, as used in PostgreSQL 7.4 before 7.4.29, 8.0 before 8.0.25, 8.1 before 8.1.21, 8.2 before 8.2.17, 8.3 before 8.3.11, 8.4 before 8.4.4, and 9.0 Beta before 9.0 Beta 2, allows context-dependent attackers to bypass intended (1) Safe::reval and (2) Safe::rdo access restrictions, and inject and execute arbitrary code, via vectors involving subroutine references and delayed execution.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2051-1, DSA-2267-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)squeeze, squeeze (security)5.10.1-17squeeze6fixed
wheezy5.14.2-21+deb7u2fixed
jessie5.20.2-3fixed
stretch, sid5.20.2-6fixed
postgresql-8.4 (PTS)squeeze8.4.21-0squeeze1fixed
squeeze (security)8.4.20-0squeeze1fixed
squeeze (lts)8.4.22lts2-0+deb6u2fixed
wheezy8.4.22-0+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.12.3-1high
perlsourcelenny5.10.0-19lenny5highDSA-2267-1
perlsourcesqueeze5.10.1-17squeeze2highDSA-2267-1
postgresql-8.3source(unstable)(unfixed)high
postgresql-8.3sourcelenny8.3.11-0lenny1highDSA-2051-1
postgresql-8.4source(unstable)8.4.4-1high

Notes

Originally attributed to Postgres, but also affects standard Perl

Search for package or bug name: Reporting problems