CVE-2010-1618

NameCVE-2010-1618
DescriptionCross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2115-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs495542, 574757
Debian/oldstablepackage glpi is vulnerable; however, the security impact is unimportant.
Debian/stablepackage glpi is vulnerable; however, the security impact is unimportant.
Debian/testingpackage glpi is vulnerable; however, the security impact is unimportant.
Debian/unstablepackage glpi is vulnerable; however, the security impact is unimportant.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glpi (PTS)squeeze0.72.4-2.1vulnerable
wheezy0.83.31-1vulnerable
jessie, sid0.84.8+dfsg.1-1vulnerable
moodle (PTS)squeeze1.9.9.dfsg2-2.1+squeeze4fixed
squeeze (security)1.9.9.dfsg2-2.1+squeeze3fixed
sid2.7.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glpisource(unstable)(unfixed)unimportant
libphp-casITP495542
moodlesource(unstable)1.9.8-1low574757
moodlesourcelenny1.8.13-1mediumDSA-2115-1

Notes

Only supported behind an authenticated HTTP zone

Search for package or bug name: Reporting problems