CVE-2010-1623

NameCVE-2010-1623
DescriptionMemory leak in the apr_brigade_split_line function in buckets/apr_brigade.c in the Apache Portable Runtime Utility library (aka APR-util) before 1.3.10, as used in the mod_reqtimeout module in the Apache HTTP Server and other software, allows remote attackers to cause a denial of service (memory consumption) via unspecified vectors related to the destruction of an APR bucket.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2117-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8fixed
buster (security)2.4.38-3+deb10u7fixed
bullseye2.4.54-1~deb11u1fixed
bullseye (security)2.4.52-1~deb11u2fixed
bookworm2.4.54-3fixed
sid2.4.54-5fixed
apr-util (PTS)buster1.6.1-4fixed
bookworm, sid, bullseye1.6.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcelenny(not affected)
apache2source(unstable)2.2.16-3
apr-utilsourcelenny1.2.12+dfsg-8+lenny5DSA-2117-1
apr-utilsource(unstable)1.3.9+dfsg-4medium

Notes

[lenny] - apache2 <not-affected> (vulnerable code introduced in 2.2.15-2 or -3)

Search for package or bug name: Reporting problems