CVE-2010-1634

NameCVE-2010-1634
DescriptionMultiple integer overflows in audioop.c in the audioop module in Python 2.6, 2.7, 3.1, and 3.2 allow context-dependent attackers to cause a denial of service (application crash) via a large fragment, as demonstrated by a call to audioop.lin2lin with a long string in the first argument, leading to a buffer overflow. NOTE: this vulnerability exists because of an incorrect fix for CVE-2008-3143.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs599739

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie2.7.9-2+deb8u1fixed
jessie (security)2.7.9-2+deb8u5fixed
stretch (security), stretch2.7.13-2+deb9u3fixed
buster2.7.16-2fixed
bullseye, sid2.7.16-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.4source(unstable)(unfixed)low
python2.5source(unstable)2.5.5-10low599739
python2.6source(unstable)2.6.6-1low
python2.7source(unstable)2.7-1low
python3.1source(unstable)3.1.2+20100822-1low

Notes

[lenny] - python2.5 <no-dsa> (Minor issue)
[lenny] - python2.4 <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems