CVE-2010-1675

NameCVE-2010-1675
Descriptionbgpd in Quagga before 0.99.18 allows remote attackers to cause a denial of service (session reset) via a malformed AS_PATHLIMIT path attribute.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2197-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)squeeze, squeeze (security)0.99.20.1-0+squeeze5fixed
wheezy, wheezy (security)0.99.22.4-1+wheezy1fixed
jessie0.99.23.1-1fixed
stretch, sid0.99.24.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.18-1medium
quaggasourcelenny0.99.10-1lenny5mediumDSA-2197-1
quaggasourcesqueeze0.99.17-2+squeeze2mediumDSA-2197-1

Search for package or bug name: Reporting problems