CVE-2010-1678

NameCVE-2010-1678
DescriptionMapserver 5.2, 5.4 and 5.6 before 5.6.5-2 improperly validates symbol index values during Mapfile parsing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)jessie (security), jessie6.4.1-5+deb8u3fixed
stretch7.0.4-2fixed
buster7.2.2-1fixed
bullseye, sid7.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)5.6.5-2

Notes

http://trac.osgeo.org/mapserver/ticket/3641

Search for package or bug name: Reporting problems