CVE-2010-1679

NameCVE-2010-1679
DescriptionDirectory traversal vulnerability in dpkg-source in dpkg before 1.14.31 and 1.15.x allows user-assisted remote attackers to modify arbitrary files via directory traversal sequences in a patch for a source-format 3.0 package.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2142-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpkg (PTS)wheezy1.16.18fixed
wheezy (security)1.16.17fixed
jessie1.17.27fixed
jessie (security)1.17.26fixed
stretch1.18.24fixed
buster, sid1.19.0.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpkgsource(unstable)1.15.8.8medium
dpkgsourcelenny1.14.31mediumDSA-2142-1

Search for package or bug name: Reporting problems