CVE-2010-1767

NameCVE-2010-1767
DescriptionCross-site request forgery (CSRF) vulnerability in loader/DocumentThreadableLoader.cpp in WebCore in WebKit before r57041, as used in Google Chrome before 4.1.249.1059, allows remote attackers to hijack the authentication of unspecified victims via a crafted synchronous preflight XMLHttpRequest operation.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze, squeeze (security)6.0.472.63~r59945-5+squeeze6fixed
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie43.0.2357.65-1~deb8u1fixed
jessie (security)44.0.2403.89-1~deb8u1fixed
stretch, sid44.0.2403.107-1fixed
webkit (PTS)squeeze1.2.7-0+squeeze2fixed
squeeze (security)1.2.7-0+squeeze1fixed
wheezy1.8.1-3.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)5.0.375.29~r46008-1medium
webkitsource(unstable)1.2.1-3medium

Notes

[lenny] - webkit <no-dsa> (Unmaintained in Lenny, only affects fringe apps)
https://bugs.webkit.org/show_bug.cgi?id=36843
http://trac.webkit.org/changeset/57041

Search for package or bug name: Reporting problems