CVE-2010-1783

NameCVE-2010-1783
DescriptionWebKit in Apple Safari before 5.0.1 on Mac OS X 10.5 through 10.6 and Windows, and before 4.1.1 on Mac OS X 10.4; and webkitgtk before 1.2.6; does not properly handle dynamic modification of a text node, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted HTML document.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2188-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze (security), squeeze6.0.472.63~r59945-5+squeeze6fixed
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie40.0.2214.111-1fixed
sid41.0.2272.76-1fixed
webkit (PTS)squeeze1.2.7-0+squeeze2fixed
squeeze (security)1.2.7-0+squeeze1fixed
wheezy1.8.1-3.4fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)5.0.375.127~r55887-1high
webkitsource(unstable)1.2.7-1high
webkitsourcesqueeze1.2.7-0+squeeze1highDSA-2188-1

Notes

(Chromium Sec) This seems a duplicate of CVE-2010-2899
http://trac.webkit.org/changeset/62134

Search for package or bug name: Reporting problems