CVE-2010-2055

NameCVE-2010-2055
DescriptionGhostscript 8.71 and earlier reads initialization files from the current working directory, which allows local users to execute arbitrary PostScript commands via a Trojan horse file, related to improper support for the -P- option to the gs program, as demonstrated using gs_init.ps, a different vulnerability than CVE-2010-4820.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs584653, 584663, 592569

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7fixed
jessie (security)9.26a~dfsg-0+deb8u6fixed
stretch (security), stretch9.26a~dfsg-0+deb9u6fixed
buster, buster (security)9.27~dfsg-2+deb10u3fixed
bullseye, sid9.50~dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)8.71~dfsg2-6.1584653, 584663, 592569

Notes

[lenny] - ghostscript <no-dsa> (too risky for regressions)

Search for package or bug name: Reporting problems