|Description||Apache Tomcat 5.5.0 through 5.5.29, 6.0.0 through 6.0.27, and 7.0.0 beta does not properly handle an invalid Transfer-Encoding header, which allows remote attackers to cause a denial of service (application outage) or obtain sensitive information via a crafted header that interferes with "recycling of a buffer."|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)|
|NVD severity||medium (attack range: remote)|
Vulnerable and fixed packages
The table below lists information on source packages.
|tomcat6 (PTS)||wheezy (security), wheezy||6.0.45+dfsg-1~deb7u1||fixed|
|jessie (security), jessie||6.0.45+dfsg-1~deb8u1||fixed|
The information below is based on the following data on fixed versions.
[lenny] - tomcat6 <not-affected> (Only ships the servlet package)