CVE-2010-2284

NameCVE-2010-2284
DescriptionBuffer overflow in the ASN.1 BER dissector in Wireshark 0.10.13 through 1.0.13 and 1.2.0 through 1.2.8 has unknown impact and remote attack vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2066-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18fixed
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie1.12.1+g01b65bf-4+deb8u11fixed
jessie (security)1.12.1+g01b65bf-4+deb8u12fixed
stretch2.2.6+g32dac6a-2fixed
stretch (security)2.2.6+g32dac6a-2+deb9u1fixed
buster, sid2.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.2.9-1high
wiresharksourcelenny1.0.2-3+lenny9highDSA-2066-1

Search for package or bug name: Reporting problems