CVE-2010-2449

NameCVE-2010-2449
DescriptionGource through 0.26 logs to a predictable file name (/tmp/gource-$UID.tmp), enabling attackers to overwrite an arbitrary file via a symlink attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs577958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gource (PTS)jessie0.43-1fixed
stretch0.44-1fixed
bullseye, sid, buster0.49-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gourcesource(unstable)0.26-2low577958

Search for package or bug name: Reporting problems