CVE-2010-2451

NameCVE-2010-2451
DescriptionMultiple format string vulnerabilities in the DCC functionality in KVIrc 3.4 and 4.0 have unspecified impact and remote attack vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2065-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kvirc (PTS)squeeze4:4.0.2-1fixed
wheezy4:4.1.3+20111124.svn5988-2fixed
stretch, sid, jessie4:4.2.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kvircsource(unstable)4:4.0.0~svn4340+rc3-1high
kvircsourcelenny2:3.4.0-5highDSA-2065-1

Search for package or bug name: Reporting problems