CVE-2010-2479

NameCVE-2010-2479
DescriptionCross-site scripting (XSS) vulnerability in HTML Purifier before 4.1.1, as used in Mahara and other products, when the browser is Internet Explorer, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2067-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs593301
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
knowledgeroot (PTS)squeeze, wheezy0.9.9.5-6fixed
mahara (PTS)squeeze (security)1.2.6-2+squeeze6fixed
moodle (PTS)squeeze1.9.9.dfsg2-2.1+squeeze4fixed
squeeze (security)1.9.9.dfsg2-2.1+squeeze3fixed
sid2.7.9+dfsg-1fixed
php-htmlpurifier (PTS)squeeze4.1.1+dfsg1-1fixed
wheezy4.4.0+dfsg1-1fixed
stretch, jessie, sid4.6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
knowledgerootsource(unstable)0.9.9.5-5medium
maharasource(unstable)1.2.5-1medium
maharasourcelenny1.0.4-4+lenny6mediumDSA-2067-1
moodlesource(unstable)1.9.9.dfsg2-1low593301
moodlesourcelenny(not affected)
php-htmlpurifiersource(unstable)4.1.1+dfsg1-1medium

Notes

[lenny] - moodle <not-affected> (doesn't ship/use htmlpurifier)
[lenny] - knowledgeroot <no-dsa> (low)

Search for package or bug name: Reporting problems