CVE-2010-2539

NameCVE-2010-2539
DescriptionBuffer overflow in the msTmpFile function in maputil.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 allows local users to cause a denial of service via vectors involving names of temporary files.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2079-1
NVD severitylow (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)squeeze5.6.5-2+squeeze3fixed
squeeze (security)5.6.5-2+squeeze2fixed
wheezy6.0.1-3.2+deb7u2fixed
sid, jessie6.4.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)5.6.4-1low
mapserversourcelenny5.0.3-3+lenny5lowDSA-2079-1

Search for package or bug name: Reporting problems