CVE-2010-2540

NameCVE-2010-2540
Descriptionmapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2079-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)squeeze5.6.5-2+squeeze3fixed
squeeze (security)5.6.5-2+squeeze2fixed
wheezy6.0.1-3.2+deb7u2fixed
jessie6.4.1-5fixed
stretch7.0.0-1fixed
sid7.0.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)5.6.4-1high
mapserversourcelenny5.0.3-3+lenny5highDSA-2079-1

Search for package or bug name: Reporting problems