CVE-2010-2640

NameCVE-2010-2640
DescriptionArray index error in the PK font parser in the dvi-backend component in Evince 2.32 and earlier allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted font in conjunction with a DVI file that is processed by the thumbnailer.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2357-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs609534
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
evince (PTS)squeeze, squeeze (security)2.30.3-2+squeeze1fixed
wheezy3.4.0-3.1fixed
sid, stretch, jessie3.14.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
evincesource(unstable)2.30.3-2high609534
evincesourcelenny2.22.2-4~lenny2highDSA-2357-1

Search for package or bug name: Reporting problems