CVE-2010-2787

NameCVE-2010-2787
Descriptionapi.php in MediaWiki before 1.15.5 does not prevent use of public caching headers for private data, which allows remote attackers to bypass intended access restrictions and obtain sensitive information by retrieving documents from an HTTP proxy cache that has been used by a victim.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs590660

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3fixed
stretch (security)1:1.27.7-1~deb9u5fixed
buster1:1.31.7-1~deb10u1fixed
buster (security)1:1.31.10-1~deb10u1fixed
bullseye, sid1:1.35.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.15.5-1low590660

Notes

[lenny] - mediawiki <no-dsa> (Minor issue)
http://lists.wikimedia.org/pipermail/mediawiki-announce/2010-July/000092.html

Search for package or bug name: Reporting problems