CVE-2010-2795

NameCVE-2010-2795
DescriptionphpCAS before 1.1.2 allows remote authenticated users to hijack sessions via a query string containing a crafted ticket value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2172-1
NVD severitymedium (attack range: remote)
Debian Bugs495542, 601384

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glpi (PTS)wheezy0.83.31-1vulnerable
jessie0.84.8+dfsg.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glpisource(unstable)(unfixed)unimportant
libphp-casITP495542
moodlesource(unstable)1.9.9.dfsg2-2medium601384
moodlesourcelenny1.8.13-3mediumDSA-2172-1

Notes

Only supported behind an authenticated HTTP zone

Search for package or bug name: Reporting problems