CVE-2010-2807

NameCVE-2010-2807
DescriptionFreeType before 2.4.2 uses incorrect integer data types during bounds checking, which allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted font file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2105-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freetype (PTS)squeeze, squeeze (security)2.4.2-2.1+squeeze4fixed
squeeze (lts)2.4.2-2.1+squeeze5fixed
wheezy2.4.9-1.1fixed
wheezy (security)2.4.9-1.1+deb7u1fixed
jessie2.5.2-3fixed
stretch, sid2.5.2-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freetypesource(unstable)2.4.2-1medium
freetypesourcelenny2.3.7-2+lenny3mediumDSA-2105-1

Search for package or bug name: Reporting problems