CVE-2010-3053

NameCVE-2010-3053
Descriptionbdf/bdflib.c in FreeType before 2.4.2 allows remote attackers to cause a denial of service (application crash) via a crafted BDF font file, related to an attempted modification of a value in a static string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2105-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freetype (PTS)stretch2.6.3-3.2+deb9u1fixed
stretch (security)2.6.3-3.2+deb9u2fixed
buster, buster (security)2.9.1-3+deb10u2fixed
bookworm, sid, bullseye2.10.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freetypesourcelenny2.3.7-2+lenny3DSA-2105-1
freetypesource(unstable)2.4.2-1

Search for package or bug name: Reporting problems