CVE-2010-3055

NameCVE-2010-3055
DescriptionThe configuration setup script (aka scripts/setup.php) in phpMyAdmin 2.11.x before 2.11.10.1 does not properly restrict key names in its output file, which allows remote attackers to execute arbitrary PHP code via a crafted POST request.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2097-1, DSA-2097-2
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)squeeze (security), squeeze4:3.3.7-7fixed
squeeze (lts)4:3.3.7-8fixed
wheezy, wheezy (security)4:3.4.11.1-2+deb7u1fixed
jessie, sid4:4.2.12-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:3.0.0high
phpmyadminsourcelenny4:2.11.8.1-5+lenny6highDSA-2097-2

Notes

Affects only 2.x branch

Search for package or bug name: Reporting problems