CVE-2010-3173

NameCVE-2010-3173
DescriptionThe SSL implementation in Mozilla Firefox before 3.5.14 and 3.6.x before 3.6.11, Thunderbird before 3.0.9 and 3.1.x before 3.1.5, and SeaMonkey before 2.0.9 does not properly set the minimum key length for Diffie-Hellman Ephemeral (DHE) mode, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via a brute-force attack.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2123-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)squeeze, squeeze (security)3.12.8-1+squeeze7fixed
squeeze (lts)3.12.8-1+squeeze11fixed
wheezy2:3.14.5-1+deb7u3fixed
wheezy (security)2:3.14.5-1+deb7u4fixed
jessie2:3.17.2-1.1fixed
stretch, sid2:3.19-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsssource(unstable)3.12.8-1high
nsssourcelenny3.12.3.1-0lenny2highDSA-2123-1

Search for package or bug name: Reporting problems