CVE-2010-3275

NameCVE-2010-3275
Descriptionlibdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an AMV file, related to a "dangling pointer vulnerability."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2211-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze, squeeze (security)1.1.3-1squeeze6fixed
wheezy2.0.3-5+deb7u1fixed
wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.0~rc2-2fixed
jessie (security)2.2.0~rc2-2+deb8u1fixed
stretch2.2.1-2fixed
sid2.2.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)1.1.8-1high
vlcsourcelenny0.8.6.h-4+lenny3highDSA-2211-1
vlcsourcesqueeze1.1.3-1squeeze4highDSA-2211-1

Notes

fe44129dc6509b3347113ab0e1a0524af1e0dd11 in 1.1 branch

Search for package or bug name: Reporting problems