CVE-2010-3434

NameCVE-2010-3434
DescriptionBuffer overflow in the find_stream_bounds function in pdf.c in libclamav in ClamAV before 0.96.3 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PDF document. NOTE: some of these details are obtained from third party information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)stretch0.102.3+dfsg-0~deb9u1fixed
stretch (security)0.102.4+dfsg-0+deb9u2fixed
buster0.103.3+dfsg-0+deb10u1fixed
bullseye0.103.3+dfsg-0+deb11u1fixed
bookworm, sid0.103.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsourcelenny(unfixed)end-of-life
clamavsource(unstable)0.96.3+dfsg-1

Notes

libclamav/pdf.c: Add missing boundscheck to pdf code (bb #2226)

Search for package or bug name: Reporting problems