DescriptionThe PostScriptFunction::PostScriptFunction function in poppler/ in the PDF parser in poppler 0.8.7 and possibly other versions up to 0.15.1, and possibly other products, allows context-dependent attackers to cause a denial of service (crash) via a PDF file that triggers an uninitialized pointer dereference.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs599165

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4fixed
jessie (security)0.26.5-2+deb8u7fixed
stretch (security), stretch0.48.0-2+deb9u2fixed
buster, sid0.71.0-2fixed
xpdf (PTS)jessie3.03-17fixed
buster, sid3.04-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssourcelenny(not affected)
popplersourcelenny(not affected)
xpdfsourcelenny(not affected)


[lenny] - kdegraphics <not-affected> (Vulnerable code not present)
[lenny] - xpdf <not-affected> (Vulnerable code not present)
[lenny] - poppler <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems