CVE-2010-3703

NameCVE-2010-3703
DescriptionThe PostScriptFunction::PostScriptFunction function in poppler/Function.cc in the PDF parser in poppler 0.8.7 and possibly other versions up to 0.15.1, and possibly other products, allows context-dependent attackers to cause a denial of service (crash) via a PDF file that triggers an uninitialized pointer dereference.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs599165

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)bullseye (security), bullseye20.09.0-3.1+deb11u1fixed
bookworm22.12.0-2fixed
sid, trixie24.02.0-5fixed
xpdf (PTS)bullseye3.04+git20210103-3fixed
bookworm3.04+git20220601-1fixed
sid, trixie3.04+git20240613-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssourcelenny(not affected)
kdegraphicssource(unstable)4:4.0.0-1
popplersourcelenny(not affected)
popplersource(unstable)0.12.4-1.2599165
xpdfsourcelenny(not affected)
xpdfsource(unstable)3.02-9

Notes

[lenny] - kdegraphics <not-affected> (Vulnerable code not present)
[lenny] - xpdf <not-affected> (Vulnerable code not present)
[lenny] - poppler <not-affected> (Vulnerable code not present)
http://cgit.freedesktop.org/poppler/poppler/commit/?id=bf2055088a3a2d3bb3d3c37d464954ec1a25771f

Search for package or bug name: Reporting problems