CVE-2010-3704

NameCVE-2010-3704
DescriptionThe FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a PDF file with a crafted PostScript Type1 font that contains a negative array index, which bypasses input validation and triggers memory corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2119-1, DSA-2135-1
NVD severitymedium (attack range: remote)
Debian Bugs599165

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6fixed
wheezy (security)0.18.4-6+deb7u4fixed
jessie (security), jessie0.26.5-2+deb8u1fixed
stretch0.48.0-2fixed
buster, sid0.61.1-2fixed
xpdf (PTS)wheezy3.03-10fixed
jessie3.03-17fixed
stretch3.04-4fixed
buster, sid3.04-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:4.0.0-1medium
popplersource(unstable)0.12.4-1.2medium599165
popplersourcelenny0.8.7-4mediumDSA-2119-1
xpdfsource(unstable)3.02-9medium
xpdfsourcelenny3.02-1.4+lenny3mediumDSA-2135-1

Notes

http://cgit.freedesktop.org/poppler/poppler/commit/?id=39d140bfc0b8239bdd96d6a55842034ae5c05473

Search for package or bug name: Reporting problems