CVE-2010-3710

NameCVE-2010-3710
DescriptionStack consumption vulnerability in the filter_var function in PHP 5.2.x through 5.2.14 and 5.3.x through 5.3.3, when FILTER_VALIDATE_EMAIL mode is used, allows remote attackers to cause a denial of service (memory consumption and application crash) via a long e-mail address string.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2195-1
NVD severitymedium (attack range: remote)
Debian Bugs601619
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.41-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.9+dfsg-0+deb8u1fixed
stretch, sid5.6.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.3.3-3medium601619
php5sourcelenny5.2.6.dfsg.1-1+lenny10mediumDSA-2195-1
php5sourcesqueeze5.3.3-7+squeeze1mediumDSA-2195-1

Search for package or bug name: Reporting problems