CVE-2010-3908

NameCVE-2010-3908
DescriptionFFmpeg before 0.5.4, as used in MPlayer and other products, allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a malformed WMV file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2306-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.1.2-1fixed
sid7:3.1.3-1fixed
libav (PTS)wheezy6:0.8.17-2fixed
wheezy (security)6:0.8.17-2+deb7u2fixed
jessie6:11.6-1~deb8u1fixed
jessie (security)6:11.7-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1medium
ffmpegsourcesqueeze4:0.5.4-1mediumDSA-2306-1
ffmpeg-debiansource(unstable)(unfixed)end-of-life
libavsource(unstable)4:0.6-1medium

Search for package or bug name: Reporting problems