CVE-2010-4008

NameCVE-2010-4008
Descriptionlibxml2 before 2.7.8, as used in Google Chrome before 7.0.517.44, Apple Safari 5.0.2 and earlier, and other products, reads from invalid memory locations during processing of malformed XPath expressions, which allows context-dependent attackers to cause a denial of service (application crash) via a crafted XML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2128-1
NVD severitymedium (attack range: remote)
Debian Bugs602609

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5fixed
wheezy (security)2.8.0+dfsg1-7+wheezy11fixed
jessie (security), jessie2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster2.9.4+dfsg1-5.1fixed
sid2.9.4+dfsg1-5.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.7.8.dfsg-1medium602609
libxml2sourcelenny2.6.32.dfsg-5+lenny2mediumDSA-2128-1

Search for package or bug name: Reporting problems